• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Axis SoapMonitor woes

Baba Bizlowsky
Ranch Hand
Posts: 39
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everybody.

A few months ago I played with the Axis SOAP Monitor by following the instructions on http://nagoya.apache.org/wiki/apachewiki.cgi?AxisProjectPages/SoapMonitor and everything worked great.

In the meantime I uninstalled everything and recently installed it back. I tried activating SOAPMonitor again, follows exactly the same instructions, but upon starting the SOAPMonitor applet I get:

The SOAP Monitor is unable to communcate with the server.

I tried everything, checked every line, but it just doesn't want to work properly.

Please help me. I have to demonstrate SOAP communication in a few days and this tool is very important to me.

P.S. Exception in Java console reads as follows:

Exception! java.net.BindException: Cannot assign requested address: connect

java.net.BindException: Cannot assign requested address: connect
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.PlainSocketImpl.doConnect(Unknown Source)
at java.net.PlainSocketImpl.connectToAddress(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at java.net.Socket.<init>(Unknown Source)
at SOAPMonitorApplet$SOAPMonitorPage.start(SOAPMonitorApplet.java:394)
at SOAPMonitorApplet.start(SOAPMonitorApplet.java:137)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

P.P.S. By digging through the SoapMonitorApplet code I saw that this line is the reason (I wrote just the important parts of the code):

int port;

public void init() {
String port_str = getParameter("port");
if (port_str != null) {
port = Integer.parseInt(port_str);

public void start() {
String codehost = getCodeBase().getHost();
if (socket == null) {
try {
// Open the socket to the server
socket = new Socket(codehost, port);
// Create output stream
out = new ObjectOutputStream(socket.getOutputStream());
// Create input stream and start background
// thread to read data from the server
in = new ObjectInputStream(socket.getInputStream());
new Thread(this).start();
} catch (Exception e) {

As you can see, I debugged it with System.out.println's and I saw that the port variable reads as 0, which can't be right. I tried changing the bold line to open with 8080 instead of the read parameter, but it still doesn't work, although with a different exception, "java.io.StreamCorruptedException: Caught EOFException while reading the stream header".

Again,please help me if you can.
[ June 06, 2004: Message edited by: Baba Bizlowsky ]
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic