Win a copy of Practical SVG this week in the HTML/CSS/JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

SOAP and WSAD V5.0

 
Matt James
Greenhorn
Posts: 22
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

Got a problem with SOAP in WSAD V5.0.

Have configured my Soap Servlet and deployed the services I need. These have deployed succesfully but when I try and run the service it falls over because it cannot resolve one of the type mappings defined in my service deployment descriptor.

The EAR uses a WAR module where everything is set up. The WAR should be able to see the 'unresolved' class as it has all my source projects set up as virtual JAR's at runtime.

Can anyone help ?
 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
can u post ur full service descriptor here ?

what web services runtime you are using, websphere or axis for developing your web service ?

are you able to access the wsdl for your web service ?
 
Matt James
Greenhorn
Posts: 22
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks but its sorted now.
I was running a WSAD Test Environent Server with a EAR that used a WAR. I had the soap.jar in the ear/lib and it seemed to ignore the WAR completely. Once I moved soap.jar to the war web-inf\lib, and changed the classloader on the WAR to PARENT-LAST, then it worked.

The issue was not knowing how the class loaders were working in WSAD, rather than SOAP.

Cheers Matt
 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Matt,

Your response helped me a lot. I am able to successfully setup Axis 1.2 RC2 as web module and expose an EJB (module) as Web Service on WebSphere 5.0 and successfully able to consume the web service using AXIS stubs.


Thanks & Regards,
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!