Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Axis - strange bug in generated XML  RSS feed

 
Sol Mayer-Orn
Ranch Hand
Posts: 311
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I've run into a bug with the WSDL generated by Apache Axis.
Was wondering whether anyone else has experienced it ?

The problem is, when I deploy an Axis web service under Oracle9i-Jdeveloper, the generated WSDL has and unqualified "< types >" element. Namely, it's just < types > instead of < wsdl:types >. This only happens with "types" - other elements are fine (e.g < wsdl:message > ).

When I run the exact same application under Websphere (still using Axis, and not any IBM utilities), the WSDL is fine !

Here's what it looks like (my < types > includes the details on a simple bean called "Product" ).




Additional relevant details:
- Axis version: 1.2RC (I've also tried Axis 1.1 and Axis 1.0 with no luck)
- JDK: 1.3 (customer's requirement... note my Axis service works despite the fact JDK 1.3 didn't have an XML parser. So I assume Axis uses a parser provided by the application server environment - websphere or jdeveloper)

Any ideas would be greatly appreciated .
Thanks a lot in advance
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!