• Post Reply Bookmark Topic Watch Topic
  • New Topic

Help! Install Axis to JBoss Error

 
Lilly Wiesie
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I tried to install Axis 1.2 to JBoss 4.0. Basically I dropped the axis.war to Jboss\server\default\deploy. When I tried to view the list of web services, I got the following exception:

org.apache.axis.ConfigurationException: java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.net.axis.server.JBossAuthenticationHandler
java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.net.axis.server.JBossAuthenticationHandler

Could anybody tell me what can I do to fix the problem?

Million thanks.

Lilly
 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JBoss application server has its implementation of AXIS SOAP Engine, called as JBossWS and this creates conflict with Apache AXIS SOAP Engine Version. I am not sure about your problem but it can be a useful guess and so try deleting the 2 directories server\default\deploy\ebxmlrr-service.sar
server\default\deploy\jboss-ws4ee.sar ....
 
nirav thaker
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey RRKumaran,

That helped, thanks.

Nirav Thaker
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!