• Post Reply Bookmark Topic Watch Topic
  • New Topic

How to deploy a web service on Websphere 5.0.1

 
Gaelle SMITS
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello !

I need to install a web service on Websphere, but we only have it in its 5.0.1 version.
I can find everywhere information about deploying web services on WAS 5.0.2 using WSDL, but I can't find if it's possible (I hope it is !) and then how to make a web service run on 5.0.1.
Please, help me, send me a good URL or any tip, I feel like I have searched everywhere !

Thanks,
Gaelle.
 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
setup AXIS as web module (after all it is implemented as servlet) inside a ear and deploy that ear on WAS5.1 and register ur services in axis's server-config.wsdd file and restart server when a new service is (un)registered.
 
Balaji Loganathan
author and deputy
Bartender
Posts: 3150
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes..thats a nice way.

Also depending on ur servlet-containver sometimes you dont need to restart ur server (example Servlet-EXEC IIS).
 
Tim West
Ranch Hand
Posts: 539
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Just to add a counterpoint: Websphere 5.0.1 must support Web services if 5.0.2 does - you wouldn't add Web services support in a minor release like that. Is there nothing on DeveloperWorks?

While using Axis is an obvious solution, it has the significant drawback that if anything goes wrong, you can't get help under your IBM support contract (which I assume you have). IMO, using Axis should be a last resort if all Websphere-inbuilt options fail.

I would guess, but it's only a guess, that the 5.0.2 documentation would largely apply to 5.0.1. Has your experience shown this to be false?


-Tim
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!