Help coderanch get a
new server
by contributing to the fundraiser
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Need HandsOn for JWSDP

 
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am new to JWSDP and want a simple to intermediate handson examples with SAAJ and JAX-RPC. I googled the same and find for AXIS but not JWSDP. Can anyone please refer me to any JWSDP tutorials / handson URL's.

Thanks in advance.
 
Bartender
Posts: 2968
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Building Web Services with JAX-RPC
Also see How to read RMH.
 
Rr Kumaran
Ranch Hand
Posts: 548
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

Thank you for your replies.

I downloaded Java Web Services Developer Pack 1.6 for Windows and
Tomcat 5.0 for Java WSDP from
http://java.sun.com/webservices/containers/tomcat_for_JWSDP_1_5.html.
I have Sun JVM 1.4.2_09-b05

When I am trying install my JWSDP and select my web container as
C:\tomcat50-jwsdp then JWSDP I get a error dialog saying
"C:\tomcat50-jwsdp is not a Sun Java System Application Server
Platform Edition 8.1, Sun Java System Web Server 6.1, or Tomcat 5.0
for Java WSDP installation directory."

Any thoughts ?


Thank You.
 
Peer Reynders
Bartender
Posts: 2968
6
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
  • If you want to use JWSDP 1.6 use the J2EE 1.4 SDK and Sun Java System Application Server Platform Edition 8.1 2005Q2 UR2.
  • If you want to use the modified tomcat servlet container revert to Java Web Services Developer Pack 1.5 Download.


  • Sun's Website keeps going on about "Note that the document about Tomcat 5.0 and Java WSDP 1.5 also applies to Java WSDP 1.6.". I can't find that document - maybe its somewhere in the download. On the other hand there are some spurious references to "Tomcat 5.0 for Java WSDP 1.6" (see right at the top of Web Container Downloads), so maybe there is going to be a "Tomcat 5.0 for Java WSDP 1.6".

    If you take a look at the JWSDP 1.5 download page you will notice that one of the web containers listed is "Tomcat 5.0 for Java WSDP 1.4 (based upon Tomcat 5.0.19)". Well, if that one worked so well, why bother creating a "Tomcat 5.0 for Java WSDP 1.5"? I wonder if we are looking at history repeating itself.
    [ October 05, 2005: Message edited by: Peer Reynders ]
     
    Rr Kumaran
    Ranch Hand
    Posts: 548
    • Mark post as helpful
    • send pies
      Number of slices to send:
      Optional 'thank-you' note:
    • Quote
    • Report post to moderator
    Thank you Peer. It works :-)
     
    "To do good, you actually have to do something." -- Yvon Chouinard
    We need your help - Coderanch server fundraiser
    https://coderanch.com/t/782867/Coderanch-server-fundraiser
    reply
      Bookmark Topic Watch Topic
    • New Topic