Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Exception in thread "main" java.lang.NoClassD...  RSS feed

 
Jay Shar
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a simple server program and a simple client program to test axis - soap-rpc style method.

I am getting errors while running my client program (for both methods - .jws as well as .wsdd)

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/commons/discovery/tools/DiscoverSingleton
at org.apache.axis.components.logger.LogFactory$1.run(LogFactory.java:45)
at java.security.AccessController.doPrivileged(Native Method)
at org.apache.axis.components.logger.LogFactory.getLogFactory(LogFactory.java:41)
at org.apache.axis.components.logger.LogFactory.<clinit>(LogFactory.java:33)
at org.apache.axis.utils.Options.<clinit>(Options.java:35)
==================================

I AM USING FOLLOWING CLASSPATH:

c:\Axis\lib\axis.jar;
c:\Axis\lib\axis-ant.jar;
c:\Axis\lib\commons-discovery-0.2.jar;
c:\Axis\lib\commons-logging.jar;
c:\Axis\lib\jax-1_1-fr-qname-class.jar;
c:\Axis\lib\jaxrpc.jar;
c:\Axis\lib\log4j-1.2.8.jar;
c:\Axis\lib\saaj.jar;
c:\Axis\lib\wsdl4j-1.5.1.jar;
c:\Axis\lib\activation.jar;
C:\Program Files\Apache Group\Tomcat 4.1\common\lib\servlet.jar

==================================

Based on the others recommendation I read I have changed some other version of "COMMANS-LOGGING.JAR", but still I am getting same errors.
Can anyone help me what may be wrong?

Instead of .jws method, I have tried .wsdd method also, I am still getting errors.

Help me!
 
Jay Shar
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Till now I have no solution...

In my organization, I do not need to write client side program in Java so I have tested client side program using third party vendor software, and now I am getting satisfactory test results.
Server side code is working fine with no change.
 
Jesus Angeles
Ranch Hand
Posts: 2069
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had same problem an hour ago.

I realized I dont have the current directory, represented by '.' (dot) in the classpath.

Try do like this on your classpath:

Old: c:\whatever;c:\more

New: .;c\whatever;c:\more

Notice the extra dot and semicolon at the start of the classpath
 
Jay Shar
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That did work fine.

Thanks
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!