• Post Reply Bookmark Topic Watch Topic
  • New Topic

having error "No compiler found in your classpath"

 
Jesus Angeles
Ranch Hand
Posts: 2069
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I do have tools.jar in my classpath. I wonder if there is a limit in the length of the classpath.


==================== client window =========================

C:\wd\book beginning jws\coding\CH3 2 PG 112>java HelloWorldClient
HelloWorld.main: Entering...
log4j:WARN No appenders could be found for logger(org.apache.axis.i18n.ProjectResourceBundle).
log4j:WARN Please initialize the log4j system properly.
Caught an exception: java.lang.RuntimeException: No compiler found in your classpath! (you may need to add 'tools.jar')
========================================================

==================== classpath =========================

.;C:\J2EE\LIB\J2EE.JAR;C:\xerces2\xerces-2_7_1\xercesImpl.jar;C:\xerce
s2\xerces-2_7_1\xml-apis.jar;c:\j2sdk1.4.2_08\lib\tools.jar;c:\xml-axis\lib\axis.jar;c:\xml-axis\lib\commons-logging-1.0.4.jar;c:\xml-axis\lib\commons-discovery-0.2.jar;c:\xml-axis\lib\jaxrpc.jar;c:\xml-axis\lib\log4j-1.2.8.jar;c:\xml-axis\lib\tt-bytecode.jar;c:\xml-axis\lib\saaj.jar;c:\xml-axis\lib\wsdl4j-1.5.1.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\providerutil.jar;c:\Program Files\IBM\W
ebSphere MQ\Java\lib\com.ibm.mqjms.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\ldap.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\jta.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\jndi.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\jms.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\connector.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\fscontext.jar;c:\Program Files\IBM\WebSphere MQ\Java\lib\com.ibm.mq.jar;.;C:\db2\java\db2java.zip;C:\db2java\db2jcc.jar;C:\db2\java\sq
lj.zip;C:\db2\java\db2jcc_license_cu.jar;C:\db2\bin;C:\db2java\common.jar;c:\j2sdk1.4.2_08\lib\tools.jar
========================================================

Any ideas?
[ November 18, 2005: Message edited by: Jesus Angeles ]
 
Jesus Angeles
Ranch Hand
Posts: 2069
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
crap...

I copied the tools.jar into Tomcat's \common\lib and it worked. It is odd. Any comments?
 
Ayub ali khan
Ranch Hand
Posts: 395
2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,

I too had similar issue, once I added tools.jar to common/lib dir the error was not displayed.

I am new to axis, I have no clue why this happened...

Thanks Ayub
[ July 24, 2006: Message edited by: Ayub ali khan ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!