Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem in using Web Services with WSAD  RSS feed

 
Ananth Prakash
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am exposing EJB as a webservice. When I'm deploying the EJB as a webservice using WSAD, the server when starting dumps core with the following exception.

JVMDG217: Dump Handler is Processing a Signal - Please Wait.
JVMDG303: JVM Requesting Java core file
JVMDG304: Java core file written to C:\Program Files\IBM\WebSphere Studio\Application Developer\v5.1.2\javacore.20060427.161130.2920.txt
JVMDG215: Dump Handler has Processed Exception Signal 11.

On exploring the Core Dump files I have seen some parsing errors in the Symbol Table class which I had no clue of.
There's an interesting twist here though. When I reduce the number of variables in my EJB classes to a certain number, the service is deployed and the server gets started properly. But when I increase the variables by 1, after a certain limit th server dumps core and fails to start. I have no clue why its happening.
I tried putting WSAD fix pack 9 but even then I had the same problem. I need toadd some new variables but am unable to do it due to this error. Could anyone pls help?
 
punna Kumar
Ranch Hand
Posts: 80
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This problem is happening only you have not sufficient Heap memory

it will cause the OutofMemory errors in WSAD

Increse the Heap Size to 512MB size by setting the JVM arguments . it may slove the problem


-Xmx512m -Xms20m

Regards,
Ravi.
 
Ananth Prakash
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I tried setting the same arguments but still I get the dump core.
I have some interesting observations which might help.
When I start the server in debug mode, the server starts up without any problem.
When I make an EAR( after the server ha dumped core) and install it on WAS server, I dont have any problems.

I just dont understand why, the WSAD server dumps core when started normally, with the scenario mentioned in my previous mail.

Could you pls give me any more leads?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!