Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

jwsdp sample wss; unable to run

 
Ranch Hand
Posts: 2107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i am trying, first time, to run the very first sample 'simple' xws set. i have just finished setting up everything according to the instructions. I am using win xp, sjsas server, and jdk 1.5.

after 'asant run-sample', i get the below. any ideas?

 
Rancher
Posts: 43016
76
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Do you have other JDKs installed besides 1.5? That's an error message you'd get if wscompile somehow was run on an older JVM.
 
Jesus Angeles
Ranch Hand
Posts: 2107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yes, actually that is what I tried just now and it worked.

I updated both asenv.bat and wscompile.bat

with

set AS_JAVA=C:\Program Files\Java\jdk1.5.0_06

The app server itself installed its own jdk 1.4. And the property above was set to it.

Thanks!

There is another occurrence of it; in wsdeploy.bat, but it hasnt given me headache yet. But if anything comes up, that should possibly be one reason.
 
Jesus Angeles
Ranch Hand
Posts: 2107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
(jwsdp 1.6 sample 'simple' sign client sign server)

for the 'simple' sample that 'sign client' and 'sign server', an error comes up, as the certificates have expired.

i got advice from users@jwsdp.dev.java.net to get the next set of files at xwss.dev.java.net

i downloaded the 4 files, and overwrote those with same name

client-keystore.jks
client-truststore.jks
server-keystore.jks
server-truststore.jks

but i get this error

any ideas?



[ June 11, 2006: Message edited by: Jesus Angeles ]
 
Jesus Angeles
Ranch Hand
Posts: 2107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it is ok now.

i copied the cert files also to the client side.

i copied it only to the server side yesterday when i was having this error; so the certs at the client are still expired.
 
Talk sense to a fool and he calls you foolish. -Euripides A foolish tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic