Win a copy of Kotlin in Action this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Log4J message and xFire Web Service Question  RSS feed

 
Mike London
Ranch Hand
Posts: 1476
10
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I went through the Web Services tutorial with xFire I found on the MyEclipse site. xFire seems to do everything I need and has simple integration into MyEclipse!

The only thing I can't seem to fix is that when I run the Web Service from the stub client program, I get the lines below:

----------------------------------------------------------

log4j:WARN No appenders could be found for logger (org.codehaus.xfire.transport.DefaultTransportManager).

log4j:WARN Please initialize the log4j system properly.
----------------------------------------------------------
It's not clear that I'm even "using" log4j from the demo.

I tried putting an old log4j.properites file in various locations in Tomcat, but I kept getting these strings as the Web Service ran.

Any advice how to get rid of these log4j status messages would be appreciated.

Thanks.

-- Mike
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!