Win a copy of Head First Agile this week in the Agile forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Does this error message look familiar?  RSS feed

 
Anthony Smith
Ranch Hand
Posts: 285
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Any ideas? I am using python to make the web service call.



Traceback (most recent call last):
File "C:\SOAPpy-0.12.0\tests\simpleWSDL.py", line 19, in ?
temp = proxy.getCurrPrimAssignRoles('411161')
File "c:\python24\Lib\site-packages\SOAPpy\Client.py", line 470, in __call__
return self.__r_call(*args, **kw)
File "c:\python24\Lib\site-packages\SOAPpy\Client.py", line 492, in __r_call
self.__hd, self.__ma)
File "c:\python24\Lib\site-packages\SOAPpy\Client.py", line 406, in __call
raise p
SOAPpy.Types.faultType: <Fault env:Server: Exception during processing: javax.xml.soap.SOAPException: Found SOAPElement [<v1 xsi:type="xsd:string">411161</v1>]. But was not able to find a Part that is registered with this Message which corresponds to this SOAPElement. The name of the element should be one of these[string] (see Fault Detail for stacktrace): <SOAPpy.Types.structType detail at 16468448>: {'stacktrace': 'javax.xml.soap.SOAPException: Found SOAPElement [<v1 xsi:type="xsd:string">411161</v1>]. But was not able to find a Part that is registered with this Message which corresponds to this SOAPElement. The name of the element should be one of these[string]\n\tat weblogic.webservice.core.DefaultMessage.toJava(DefaultMessage.java:478)\n\tat weblogic.webservice.core.handler.InvokeHandler.handleRequest(InvokeHandler.java:93)\n\tat weblogic.webservice.core.HandlerChainImpl.handleRequest(HandlerChainImpl.java:143)\n\tat weblogic.webservice.core.DefaultOperation.process(DefaultOperation.java:535)\n\tat weblogic.webservice.server.Dispatcher.process(Dispatcher.java:204)\n\tat weblogic.webservice.server.Dispatcher.doDispatch(Dispatcher.java:176)\n\tat weblogic.webservice.server.Dispatcher.dispatch(Dispatcher.java:96)\n\tat weblogic.webservice.server.WebServiceManager.dispatch(WebServiceManager.java:98)\n\tat weblogic.webservice.server.servlet.WebServiceServlet.serverSideInvoke(WebServiceServlet.java:297)\n\tat weblogic.webservice.server.servlet.ServletBase.doPost(ServletBase.java:485)\n\tat weblogic.webservice.server.servlet.WebServiceServlet.doPost(WebServiceServlet.java:267)\n\tat javax.servlet.http.HttpServlet.service(HttpServlet.java:760)\n\tat javax.servlet.http.HttpServlet.service(HttpServlet.java:853)\n\tat weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:998)\n\tat weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:419)\n\tat weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:315)\n\tat weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6508)\n\tat weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)\n\tat weblogic.security.service.SecurityManager.runAs(SecurityManager.java:118)\n\tat weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3717)\n\tat weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2630)\n\tat weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:219)\n\tat weblogic.kernel.ExecuteThread.run(ExecuteThread.java:178)\n'}>
 
meiji wang
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
did you get answer for this one? I have similar problem.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
<Fault env:Server: Exception during processing: javax.xml.soap.SOAPException: Found SOAPElement [<v1 xsi:type="xsd:string">411161</v1>]. But was not able to find a Part that is registered with this Message which corresponds to this SOAPElement. The name of the element should be one of these[string] (see Fault Detail for stacktrace): <SOAPpy.Types.structType detail at 16468448>: {'stacktrace': 'javax.xml.soap.SOAPException: Found SOAPElement [<v1 xsi:type="xsd:string">411161</v1>]. But was not able to find a Part that is registered with this Message which corresponds to this SOAPElement. The name of the element should be one of these[string]\n\tat


Indicates that the content of the SOAP message does not match what the service is expecting. At this point I would try to capture the actual text of the message being sent using TCPMON or something similar. Sometimes examination shows are really obvious error in an element name etc etc.

Bill
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!