• Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem with webservices

 
Vijay Kumar
Ranch Hand
Posts: 260
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi. All
I am new to webservices.I have created a small webservice.but when I try to invoke that service its give me java.lang.NullPointerException
Genrated log display this give message

2006-10-26 17:46:59,860 HttpReactor WARN com.alcatel.webservices.axis2.agent.AxisProxylet - AxisProxylet doPost failure 500

org.apache.axis2.AxisFault: Service Not found EPR is http://10.203.143.144:4444/webservices/VccService; nested exception is:
org.apache.axis2.AxisFault: Service Not found EPR is http://10.203.143.144:4444/webservices/VccService
at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:184)
at com.alcatel.webservices.axis2.agent.AxisProxylet.doPost(AxisProxylet.java:335)
at com.alcatel.webservices.axis2.agent.AxisProxylet.doRequest(AxisProxylet.java:128)

My wsdl file is given below.

<?xml version="1.0" encoding="UTF-8"?>
<definitions name="VccService"
targetNamespace="http://http.ias.alcatel.com/VccService"
xmlns="http://schemas.xmlsoap.org/wsdl/"
xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:tns="http://http.ias.alcatel.com/VccService"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsd1="http://http.ias.alcatel.com/xsd"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<types>


<schema targetNamespace="http://http.ias.alcatel.com/xsd"
xmlns="http://www.w3.org/2001/XMLSchema"
xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
elementFormDefault="qualified">
<complexType name="VccServiceForm">
<sequence>
<element name="vccId" type="string" minOccurs="1"/>
<element name="msIsdn" type="string" minOccurs="1"/>
<element name="sipUri" type="string" minOccurs="1"/>
<element name="result" type="string" minOccurs="1"/>
<element name="wifiToGsmAllowed" type="boolean" minOccurs="1"/>
<element name="gsmtoWifiAllowed" type="boolean" minOccurs="1"/>
<element name="inwardHandOver" type="boolean" minOccurs="1"/>
<element name="serviceActive" type="boolean" minOccurs="1"/>
</sequence>
</complexType>
<element name="inputParam" type="xsd1:VccServiceForm"/>
<element name="outputParam" type="xsd1:VccServiceForm"/>
</schema>
</types>
<message name="vccRequest">
<part element="xsd1:inputParam" name="a"/>
</message>
<message name="vccResponse">
<part element="xsd1 utputParam" name="result"/>
</message>

<portType name="VccServiceData">
<operation name="getVccServiceData">
<input message="tns:vccRequest" name="vccRequest"/>
<output message="tns:vccResponse" name="vccResponse"/>
</operation>

</portType>


<binding name="VccPortBinding" type="tns:VccServiceData">
<soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
<operation name="getVccServiceData">
<soap peration soapAction="getVccServiceData" style="document"/>
<input name="vccRequest">
<soap:body namespace="http://http.ias.alcatel.com/VccService"
use="literal"/>
</input>
<output name="vccResponse">
<soap:body namespace="http://http.ias.alcatel.com/VccService"
use="literal"/>
</output>
</operation>
</binding>



<service name="VccService">
<port binding="tns:VccPortBinding"
name="VccService">
<soap:address
location="http://@HOST@:@PORT@/webservices/VccService"/>
</port>
</service>
</definitions>

please help me out
thanks
 
Chris Nappin
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When debugging Web Services, I use the fantastic "tcpmon" tool that comes with Apache Axis. Use this to redirect your SOAP call, then at least you will know whether the fault is at the client or server end. Then at least you have a starting point...
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I absolutely agree with what Chris said. TCPMON will capture all the text of both request and response - with that in front of you the cause may become immediately apparent.

Bill
 
Vijay Kumar
Ranch Hand
Posts: 260
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok chris I use TCPMON tool.I just want ot know that is there any thing wrong with my wsdl file.

Thanks for your valuable suggession.
 
Chris Nappin
Ranch Hand
Posts: 36
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Looking at the stack trace it seems unlikely that your error is caused by the WSDL, it looks more like something more fundamental has gone wrong.

I can't see anything obviously wrong with your WSDL, except that minOccurs="1" is the default for a sequence so you don't have to explicitly state it, although that isn't going to cause any problems.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Now that you have TCPMON, look at the exact text of the request. From the error message it sounds like the request does not look like what the service is expecting.

Bill
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!