This week's giveaway is in the JDBC forum.
We're giving away four copies of Java Database Connections & Transactions (e-book only) and have Marco Behler on-line!
See this thread for details.
Win a copy of Java Database Connections & Transactions (e-book only) this week in the JDBC forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Knute Snortum
  • Paul Clapham
  • Tim Cooke
Sheriffs:
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Frits Walraven
Bartenders:
  • Ganesh Patekar
  • Tim Holloway
  • salvin francis

errors deploying aar files  RSS feed

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi all,
I could manage to deploy the axis2 web application on Web Sphere 5.1 test server but I could not get the services to work .I am getting the following error for version service when deployed as version.aar
---------
33aeb2fa DeploymentEng I org.apache.axis2.deployment.DeploymentEngine Invalid service version.aar due to java.lang.NoSuchMethodError: javax.xml.namespace.QName: method <init>(Ljava/lang/String;Ljava/lang/String;Ljava/lang/String V not found
at org.apache.ws.java2wsdl.utils.TypeTable.populateSimpleTypes(TypeTable.java:38)
-----------
Can any one pl lemme know what this problem is ?
Thanks in advance
Prasad.
 
Greenhorn
Posts: 9
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

This seems to be a jar versioning issue. In the was console try making the classloader policy as PARENT_FIRST and try. This may solve your problem.

Sashwat
 
Prasad Lakkavaram
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks William and Sashwat for your suggestions. I was able to get webService and client to work using axis2 using their wizards . I actually used axis2-1.1.1 nightly build to get them working.

I have another question about client code generated using webservices toolkit on Excel 2003 if any of you have worked on this before.
I have used http://www.oreilly.com/pub/h/1306
to test the webservice on Excel. When I created the webservice using websphere soap engine on rad 6.0 Excel created structures (VB code) for all my DTOs with that wsdl one of my input objects is mapped to
ex: struct_OpportunityCountRequ with fields
Public nwieId As String
Public oppLibId As Double
Public producerNumber As String
Public mailable As Boolean

but when I created wsdl from axis2 soap engine ( axis2 wizards added as plugin to RAD 6.0) then I could not get the structures for the DTOS of my webservice methods .Instead I have all the DTOS mapped to MSXML2.IXMLDOMNodeList in VB code

Could any one let me the reason for this difference in code generation ?
I would appreciate any suggestions.
Thanks,
Prasad
 
Prasad Lakkavaram
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks William and Sashwat for your suggestions. I was able to get webService and client to work using axis2 using their wizards . I actually used axis2-1.1.1 nightly build to get them working.

I have another question about client code generated using webservices toolkit on Excel 2003 if any of you have worked on this before.
I have used http://www.oreilly.com/pub/h/1306
to test the webservice on Excel. When I created the webservice using websphere soap engine on rad 6.0 Excel created structures (VB code) for all my DTOs with that wsdl one of my input objects is mapped to
ex: struct_OpportunityCountRequ with fields
Public nwieId As String
Public oppLibId As Double
Public producerNumber As String
Public mailable As Boolean

but when I created wsdl from axis2 soap engine ( axis2 wizards added as plugin to RAD 6.0) then I could not get the structures for the DTOS of my webservice methods .Instead I have all the DTOS mapped to MSXML2.IXMLDOMNodeList in VB code

Could any one let me the reason for this difference in code generation ?
I would appreciate any suggestions.
Thanks,
Prasad
 
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,
I tryng to deploy the axis2.war in weblogic81, and I obtain the same error. How I can fix the error in weblogic81?

Thanks in advance
Esther
 
Those who dance are thought mad by those who hear not the music. This tiny ad plays the bagpipes:
how do I do my own kindle-like thing - without amazon
https://coderanch.com/t/711421/engineering/kindle-amazon
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!