Only 48 hours left in the trailboss' kickstarter!

New rewards and stretch goals. CLICK HERE!



  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JWSDP problem  RSS feed

 
hani Ibrahim
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear all
i have used this tool xjc utility of JWSDP1.5
but it is generated .java files of kind j2sdk1.5 but what i want of kind 1.4.2
how is that and if there JWSDP11.4 please tell me the link of that because im novice in xml process.
 
Peer Reynders
Bartender
Posts: 2968
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JAXB 1.03 - 1.06 can be accessed through the Stable Builds link on JAXB RI page.

However if this was my problem I would first try to make sure that the only the 1.4.2 JRE/SDK was in my paths and class paths before running xjc. It may look at the accessible JRE before it decides to use a certain code standard.

There doesn't seem be a command line option for forcing the code version. If there is a way to specify it through a customization file then I haven't found it.
 
hani Ibrahim
Ranch Hand
Posts: 182
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i make sure that No java 1.5 in my classpath.but when i installed jwsdp-2.0
it forced me to install j2sk1.5..then i remove it but still generated .java files of kind 1.5
please urgent help.
 
Peer Reynders
Bartender
Posts: 2968
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by hani Ibrahim:
when i installed jwsdp-2.0.


There is your problem right there: JWSDP 2.0 and JAXB 2.0 require Java 1.5.
If you are limited to Java 1.4.2 use the Java Web Services Developer Pack 1.6 instead.
[ May 27, 2007: Message edited by: Peer Reynders ]
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!