Win a copy of The Way of the Web Tester: A Beginner's Guide to Automating Tests this week in the Testing forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

404 error while WSDL creation

veerabahu Subramanian
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

I have an environment in which there are 2 different webapps. Each webapps has its own services that are exposed using axis. I have followed the steps mentioned in the Now when i do http://<serverIP>:<port-no>/<webapp1>/servlet/AxisServlet, I am able to get all the services that are exposed by that webapp. Clicking on "wsdl" link generates the wsdl and then shows the same in XML format in the browser.
Behavior with webapp2 : On launching http://<serverIP>:<port-no>/<webapp2>/servlet/AxisServlet it shows all the services but clicking on WSDL it shows "404 error page not found".

To make sure that there are no issues with the WSDD file I deleted the WSDD from both the webapps. In this case both the webapps generates WSDD with AdminService/Version. But still the problem exist, i.e. only in webapp1 I am able to view the WSDL and not in webapp2.

Made sure that the needed jars files are available. To the best of my knowledge i made sure that there are no errors in the logs. Also double checked the entries in web.xml

My Environment: Axis deployed in Apache + Tomcat environment in a Solaris OS.

What could be reasons for WSDL generation failing. Let me know your valuable ideas to proceed further.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic