• Post Reply Bookmark Topic Watch Topic
  • New Topic

problem deploying web service + jaxws

 
Jigar Naik
Ranch Hand
Posts: 762
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have created a web service using jax-ws and i'm trying to deply it using JWSDP Web Application Manager. My service is in war file.

I have deployed the service but when i try to start the service it's giving me following error.



WSSERVLET11: failed to parse runtime descriptor: class not found in runtime descriptor: india..StockQuoteImpl

StockQuoteImpl is my implementation class(WAR/WEB-INF/classes/india/StockQuoteImpl.class) is there in the war file.
 
Ulf Dittmer
Rancher
Posts: 42970
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The extra dot in "india..StockQuoteImpl" looks suspicious.
 
Jigar Naik
Ranch Hand
Posts: 762
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ya the problem was with extra dot. i have modified it and tried to start the service but its giving me the following error



The class com.sun.xml.messaging.saaj.soap.ExpressMessageFactoryImpl, I tried to look in saaj-impl.jar but the class is not there in this jar file.
 
Ulf Dittmer
Rancher
Posts: 42970
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Then there are probably other jar files you need to include in the classpath as well. My JAX-WS installation consists of 18 jar files.
 
Jigar Naik
Ranch Hand
Posts: 762
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Progress, I can compile and almost deploy under JDK 1.6.

However i can see the following error

Caused by: java.lang.IllegalArgumentException: com.sun.xml.internal.messaging.saaj.soap.LocalStrings != com.sun.xml.messaging.saaj.soap.LocalStrings

(full trace below)


Is there any bug in WSDP ?
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!