Win a copy of Succeeding with AI this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
  • Junilu Lacar
Sheriffs:
  • Tim Cooke
  • Jeanne Boyarsky
  • Knute Snortum
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • fred rosenberger
  • Frits Walraven

Axis2 http Configuration problem

 
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I've implemented a SOAP Web Services client using AXIS2-1.3 libraries and WSDL2JAVA. I've used the following configuration to reuse the httpclient and increase the timeout period to 120 seconds, but the connection still times out after the default value of 60 seconds. The other annoying problem is that establishing a new https/ssl session is unusually slow, it takes about 5 seconds! This problem doesn't exit with other clients such as JMeter or .Net clients, so I think the problem is in my client configuration not the server.
Here is my client configuration:


stub = new myStub(url);
org.apache.axis2.client.Options options = stub._getServiceClient()
.getOptions();
options.setProperty(org.apache.axis2.transport.http.HTTPConstants.REUSE_HTTP_CLIENT, "true");

int timeOutInMilliSeconds = 120*1000;
options.setTimeOutInMilliSeconds(timeOutInMilliSeconds); // doesn't make any difference
options.setProperty( org.apache.axis2.transport.http.HTTPConstants.SO_TIMEOUT, timeOutInMilliSeconds); // No change in timeout
options.setProperty( org.apache.axis2.transport.http.HTTPConstants.CONNECTION_TIMEOUT, timeOutInMilliSeconds); // No change in timeout!

I'd appreciate your help in fixing this problem.

Thanks
Joe
 
So I left, I came home, and I ate some pie. And then I read this tiny ad:
Two software engineers solve most of the world's problems in one K&R sized book
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic