Win a copy of Rust Web Development this week in the Other Languages forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Liutauras Vilda
  • Jeanne Boyarsky
Sheriffs:
  • Junilu Lacar
  • Rob Spoor
  • Paul Clapham
Saloon Keepers:
  • Tim Holloway
  • Tim Moores
  • Jesse Silverman
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Al Hobbs
  • Piet Souris
  • Frits Walraven

Rampart/Axis2 not generating Security Header.

 
Ranch Hand
Posts: 430
Android VI Editor Debian
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hello all,

i hope someone here can help as i've spent nearly 4 days trying to get this to work. I am basicly trying to follow the example on the "Developing Web Sevices with Apache Axis2".

Everything has worked well so far but i am stuck at digitally signing SOAP messages.

Here is what i am trying to do. I have a P12 file that i want to use to sign the soap message. As described in the guide, i created this config file called "rampart-config". Notice that i've left the password entry blank as i would like to enter the password dynamically.



And here is my client. The client is basically gets the password via the MD5 has function. This password is then used to open the PKCS12 file to access the key to sign the SOAP message.


And Finally here is the WSDL File.



The problem i have with the above is that when i run it, the security header is not generated and i dont get any error to give me a hint as to what the problem is. Here is the SOAP message that is generated as shown via TCPMon



I am using the following,

Apache Axis2 v1.3
Rampart 1.3
and Java 1.5

I would really appreciate any help or guidance as to what i am doing wrong.

Thanks in advance.
reply
    Bookmark Topic Watch Topic
  • New Topic