• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

javax.microedition not found??

 
Jane Lin
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello all,
i am trying to run my first midlet but this error appears and i really really dont know how to solve it
HelloWorld.java:2: package javax.microedition.midlet.lcdui does not exist
import javax.microedition.midlet.lcdui.*;
where can i find the package?? so far i only have installed j2me wireless toolkit from java.sun.com and jdk1.3.1 is there anything else i am lacking??
thanks in advance!!
 
Richard Taylor
Author
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
All the packages you need are in the file:
<J2ME toolkit install directory>\lib\midpapi.zip
If you unzip it you will find them all (but you shouldn't need to take this step to make stuff work - its interesting though).
Not sure why yours won't work, unless you changed any of the J2MEWTK config files.
------------------
Richard Taylor
Author of Professional Java Mobile Programming
 
Jane Lin
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Richard Taylor:
All the packages you need are in the file:
<J2ME toolkit install directory>\lib\midpapi.zip
If you unzip it you will find them all (but you shouldn't need to take this step to make stuff work - its interesting though).
Not sure why yours won't work, unless you changed any of the J2MEWTK config files.

thats funny... i have included the lib\midapi in my kawa classpath i still dont know y it is not working..
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic