This week's book giveaway is in the Android forum.
We're giving away four copies of Android Programming: The Big Nerd Ranch Guide and have Bill Phillips & Chris Stewart on-line!
See this thread for details.
Win a copy of Android Programming: The Big Nerd Ranch Guide this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Build problem  RSS feed

 
Valentin Crettaz
Gold Digger
Sheriff
Posts: 7610
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi folks,
I'm currently porting an application to wireless devices using J2ME. I'm using the ktoolbar utility for building, running and packaging my MIDlets.
It doosn't work as expected though.
Here is my configuration:
J2ME 1.0.3
J2SE 1.4 beta 2
Linux Redhat 7.1 kernel 2.4.3-12 on x86
When I build my sources I got the following output

I can't figure out what this "Illegal constant pool index" means.
Does anyone have any idea ?
Thank you very much
------------------
Valentin Crettaz
Sun Certified Programmer for Java 2 Platform
 
Valentin Crettaz
Gold Digger
Sheriff
Posts: 7610
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
For those who are interested, J2ME does not like the J2SE 1.4 beta 2
I had to install "the old" 1.3.1 again and it worked...

------------------
Valentin Crettaz
Sun Certified Programmer for Java 2 Platform
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!