Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Nokia Series 60 MIDP SDK Beta 0.1 with JBuilder6

 
Andrew Parker
Ranch Hand
Posts: 178
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I installed Nokia Series 60 MIDP SDK Beta 0.1 and configured the JDK of JBuilder6.
When I run the midlet, The EPOC emulator was pop up, but then there was a runtime error:
Emulator command: C:\Nokia_Series_60_MIDP_SDK_Beta_0_1\bin\Epoc32\release\wins\udeb\kmidp_debug.exe -parent_port 2810 -classpath C:\Nokia_Series_60_MIDP_SDK_Beta_0_1\lib\j2me-debug.zip; C:\projects\test\classes;C:\Nokia_Series_60_MIDP_SDK_Beta_0_1\lib\j2me-debug.zip -descriptor c:\tmp\midp\Test.jad Test
java.lang.RuntimeException: Class not found in runMIDlet: java.lang.ClassNotFoundException: test.Test
at com.symbian.midp.compatibility.runtime.MIDletExecutor.runMIDlet(+143)
at com.symbian.midp.compatibility.runtime.MIDletMain.runFirstMIDlet(+77)
at com.symbian.midp.compatibility.runtime.MIDletMain.run(+346)
at com.sun.midp.midlet.Main.main(+56)
I changed the path to that MIDP SDK, but still failed. This test program can be run with Default J2MEwtk, motorola or Sony emulator.
What's wrong with my settings? or the software has bugs because I found that there are many developers who posted in the Nokia's support forum were unable to run it properly .
Regards
Andrew
 
Andrew Parker
Ranch Hand
Posts: 178
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Anyone encountered the same problem and had solved it?
Thanks
Andrew
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic