Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Anybody getting along with wma1.0?

 
Maulin Vasavada
Ranch Hand
Posts: 1873
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I have been trying to make WMA1.0 example (WMATester example) work for sometime but I keep running into one or the other issue.

I had WTK104 and WMA1.0 from Sun Site but I ran into following problems so far,

1. The ant script won't work. It was able to run compile target fine but preverfication failed. It gave me NoClassDefFound for Runnable class.
- I resolved that by not using Ant script and running things myself from prompt.

2. Now, I am able to compile, preverify properly but can't run targets "run1" or "run2". When I run them, I get the emulator up and when I click on "Launch" I get verification error in WMATester class's startApp()...

I tried to do some experiments but it doesn't seem to work.

I want to use WMA1.0 and MIDP1.0 as those will be supported by most of the phones. I can try MIDP2.0 but its support will be limited on devices

Anybody can help?
Regards,
Maulin
 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It might have something to do with your JDK version. You have to specify "-target 1.1" option in your javac if your JDK is 1.4 and above.
 
Maulin Vasavada
Ranch Hand
Posts: 1873
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hmmm..

I'd try it at home again and see if that works.

Thanks
Maulin
 
Maulin Vasavada
Ranch Hand
Posts: 1873
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi,

I couldn't wait try on another computer where i have jdk142_03. it works there.

It works when I try to just send SMS to another emulator's instance via port 3334 but when I try to send SMS to real phone number it doesn't work.

I don't get exception on conn.send(). Below is the code where I have put SOPs myself...



I get following output,
In SEND1
Sending the message
java.io.IOException
at com.sun.cldc.io.j2me.datagram.Protocol.receive(+77)
at com.sun.midp.io.j2me.sms.DatagramImpl$DatagramReader.run(+32)
Message sent


I am wondering if I am writing the phone number correctly. e.g.
if I have phone no: (123) 456-7890 then in the text file I should write 11234567890, right? (First '1' is for country code).

The code already prepends '+' sign in sms://+ so I am not writing that in text field.

Any idea?

I would try this on the real phone once I can upload this test to a webserver and download it on the phone to see if that makes any difference..

Regards,
Maulin
 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You cannot send messages from the emulator to a real phone. The emulator does not have access to the cellular network. You have to test this with two real phones.
 
Maulin Vasavada
Ranch Hand
Posts: 1873
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thanks Michael.

I tried it from SprintPCS's Sanyo phone and it gave me "Game/Application Terminated" deadly error known in SprintPCS phone programmers

I did some search on it and found a KVM's thread that described some possible issues and all but nothing still works for me.

Meanwhile, it works from my friend's cellphone who is in India.

So I guess I have to try out with some other phones and see where it goes.

Thanks ton for pointers so far.

When it works on SprintPCS I will jump

Regards,
Maulin
 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there a device SDK or emulator for the Sanyo phone you are working on? You can check whether this is problem with the emulator and possibly get more detailed error messages.

Also, you can try putting the SMS sending code in a separate background thread if you have not done so.
 
Rubens M. Chaves
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Maulin Vasavada,

where did you get WMA1.0 compatible with MIPD1.0? I am also trying to do a J2ME aplication to send SMS but I have just cell phone that support MIDP1.0.
Could you send a link to download it or something else that I may need to do it.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic