Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

OTA deployment issues

 
Matt Bilson
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, having problems with OTA deployment, read loads of posts in different places that sound similar, but they always seem to be sorted by adding MIME types etc, this one is proving trickier!

So the problem is, I have the .jad and the .jar on the server, in the same folder (with a relative URL in the JAD, could that be a problem??), i can find the JAD file fine and it comes up on my Sony Ericsson T610 with download and info options, innfo shows info from the JAD, and download starts downloading it, however after a few seconds, an "Invalid Application" error shows up.

The server is IIS and has a mime type for jad & jar set up, and when I bluetooth the jar to my phone (by passing the jad) it works fine, so the game is compatible with the phone

its really bugging me, as i've searched high and low on the net and can't find a solution anywhere,
any help would be very gratefully received, thanks in advance

matt
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"Matt Matt"-
Welcome to the JavaRanch! Please adjust your displayed name to meet the

JavaRanch Naming Policy.

You can change it

here.

Thanks! and welcome to the JavaRanch!

Mark
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You know I had had the same problem with my application whenever I tried to load my MIDlet onto a device.

But just yesterday I looked and realized this.

1. My Jad file had it set to MIDP 2.0, but the phone I tried it on was not MIDP 2.0 compatible, which might be the big reason why I got the same error.

I know the Sony 610 is not MIDP 2.0 compatible.

If you are using the Game API, this is MIDP 2.0 and I don't think you will be able to load it onto a Non-compatible MIDP 2.0 phone.

But Micheal would know better.

Mark
 
Matt Bilson
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
sorry!
guess i must have been signing up in a hurry and not read that!

how did u know that matt wasn't my surname as well as my first name?? i might have had very weird parents! ;-)
 
Matt Bilson
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
cheers Mark,

ermmm....the JAD for the specified file says
MIDlet-Version: 2.0

however when bluetoothed to the phone it works fine, so it must b MIDP 1 i'd have thought?? Is it that it's MIDP 1, but the JAD tells the phone its MIDP 2 so it thinks it won't b able to handle it, cos when bluetoothing, I of course only send the .jar

I've done some J2ME in the past, but these questions are regarding setting up a deployment system using content from other content providers
 
Matt Bilson
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i also have other jad's that have their versions as 1.1 or 1.25
I was under the impression (maybe wrongly) that there was MIDP 1.0 and MIDP 2.0 and that was it?

thanks again
 
Roseanne Zhang
Ranch Hand
Posts: 1953
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The problem is SonyT610 does not accept jad file. If you just give it your jar URL, it will work as good as everything else!!!
 
Matt Bilson
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it seems to accept the jad file fine, displays the information and gives an option to download the jar, which is when the problem comes about!

is that the case for other phones as well? do all phones accept jar's without the jad's because the system I'm implementing needs to work for all phones!
 
Roseanne Zhang
Ranch Hand
Posts: 1953
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
From my experiences, so far so good, they all accept jars, through jad or not.

Currently, I have 24 phone types on the tested list.
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Roseanne Zhang:
From my experiences, so far so good, they all accept jars, through jad or not.

Currently, I have 24 phone types on the tested list.



Wow. Do you buy all those phones?

I wasn't positive about the jad file and the MIDP 2.0 version being a problem, it was just that I hadn't really paid attention to it, and kind of thought maybe that was the issue.

Besides the Sony T610, I had also tried to install my application on a Nokia 6800 and had the same issue.

Rosanne, have you tried installing using a Jad file on a Nokia 6600? I am thinking about getting that phone.

Thanks

Mark

Mark
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Matt Bilson:
sorry!
guess i must have been signing up in a hurry and not read that!

how did u know that matt wasn't my surname as well as my first name?? i might have had very weird parents! ;-)


I just used my spider senses. And yes you did have very wierd parents, we all did. That's how we became programmers.

Mark
 
Roseanne Zhang
Ranch Hand
Posts: 1953
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, Mark
I had no problems with Nokia6600, not touched 6800 yet, but soon.
Roseanne
 
ayan patel
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
what you guys are doing? Any one of you tried to change MIDP VERSION IN *.JAD FILE FROM midp 2.0 to midp 1.0? I think , If application is not using any midp 2.0 APIs, you just need to make sure, that midp version should be 1.0 in JAD file(for midp 1.0 phones)........try it out!!!

And plz let me know if you succeded or not
 
manoj pillai
Ranch Hand
Posts: 41
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have run into similar problems in the past wherein the download stops in the middle with some weird error (cant remember the exact error message). It went away when I replaced the relative URL with an absolute one. You might wanna try that too.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic