• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Running MIDlets on Palm V emulator

 
Nadinha Jovan
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I downloaded the emulator and installed midp-java runtime environment to it (i can see the Java HQ icon on it). I installed the MIDlet I developed. When I attempt to run it, it starts and allows me to select the midlet I want to run. Upon selection, I receive the following error "Unable to load class javax.microedition.lcdui.CustomItem. I am not sure why is this happening since CustomItem is a part of MIDP implementation. When I ran Java HQ, it says that its version is 1.0. Does this mean that I installed midp 1.0? If that is so, I guess I need to install midp for palm os 2.0.

Thanks for your help.
 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
CustomItem is a MIDP 2.0 API. You need to install a MIDP 2.0 runtime for Palm.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic