Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

HttpConnection fails on Sony Ericsson k700i

 
Max van Anen
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, I am developing a midlet that tries to connect to a webpage.
the weird thing is. on the emulator i have to set the security domain to trusted to get the midlet to connect to the webpage. On untrusted domain, i get a confirmation screen as expected, but when i choose ok, the midlet hangs and eventually throws a javax.microedition.ConnectionNotFoundException. signing the midlet seems to work on the emulator too.
But i want to try this thing on my Sony Ericson k700i. I get the same problem as my initial problem with the emulator. This all seems a lot like a security issue. how can i resolve this though? I discovered that none of the Sun demo applications which connect via http work either, on my phone.

any help would be appreciated

Thnx in advanced

Max
 
dan moore
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the problem with midp network connections in the real world or on real phones, is that often the phone and/or operator gateway are not correctly configured.

your code may be great, it may work fine on the emulator, but that doesn't mean it will work on your phone.

usually (but not always) you should be able to google the correct settings for your network and model, or get the settings sent OTA to your phone from the manufacturer's website.

hope that helps,
dan.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic