• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Application working on Emulator not on device

 
Kavitha Kumaran
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hii

I am presently working on a Reminder application.This is an application, which allows the user to schedule the date, start time, end time and status of the meetings. The user will be alerted with a beep sound when there is a meeting scheduled at that time. The application allows the user to add, modify, delete or cancel any event from the list of events for any particular date. This information will be stored in the devices memory.

When the application starts in the startApp() of the midlet a Thread will be started where the application just reads the events from the persistant storage(rms) and i have user to a Timer and schedule a task. The task is a Alert message.The difference is between the current time and the alarmtime are calculated to set the delay for the Scheduled task to occur.
The application works fine on the emulator but not in the device. The target device is Nokia 6600.

Can anybody please tell me why it is not working ,and is there any other way to accomplish what i want.


Thanks
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When you say not working on device, do you mean you can't even install the application, or you get an error.

Remember the Emulator is using a "Default Device" and not your phone specifically. Usually if you have a target device, it is best to go to the manufacturer's website and get the emulator that they have and run it with that. then you can get a better feel for how it will work.

If you cannot install the application, it is because each device, and even Service Provider can make what it expects in a JAD file to be different, especially in MIDP 1.0.

Things in J2ME are just really touchy.

Mark
 
Kavitha Kumaran
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank u Mr.Mark

I am able to install it on the device.Now i have tested the application on the Nokia Emulator S60_2nd_FP2_MIDP_SDK. The alert is not working on the device. When i start the application and add an event at a particular time and alarm(TimerTask) is set for that particular time. In the emulator the alert is displayed correctly at that particular time. But in the emulator the alert is never displayed.

When i close tha application and start it again, only the first screen is displayed and the application automatically closes. Probably there is exception which is not caught. To debug it if i give alert messages i again get exception saying Alert cannot return Alert, i.e the time gap between the two alerts are small.

Can anybody plz help me

Thanks
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic