Win a copy of Hands On Software Engineering with Python this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Bear Bibeault
  • Knute Snortum
  • Liutauras Vilda
Sheriffs:
  • Tim Cooke
  • Devaka Cooray
  • Paul Clapham
Saloon Keepers:
  • Tim Moores
  • Frits Walraven
  • Ron McLeod
  • Ganesh Patekar
  • salvin francis
Bartenders:
  • Tim Holloway
  • Carey Brown
  • Stephan van Hulst

J2ME Polish in IntelliJ IDEA  RSS feed

 
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
How can i integrate J2MEPolish with IntelliJ IDEA 4.5.
I am using WTK2.1 and j2mepolish 1.2.4

Thanks u

Nidheesh.P
 
ranger
Posts: 17344
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I believe you have to have your project point to the jar files for J2ME Polish, now you will be able to access their classes. In the Project Settings there is a part for "Paths" in that screen there is a tab for "libraries/classpath". CLick the Add Jar/Classpath button, then select the jar files that you want to add to your classpath, and voila.

Mark
 
Nidheesh Puthalath
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank u Mark.

That is done.
but still IntelliJ shows syntax errors(editor shows red color) in the classpath property of taskdef tag.
below is the taskdef tag of my build.xml file.

<taskdef name="j2mepolish"
classname="de.enough.polish.ant.PolishTask"
classpath="${polish.home}/import/enough-j2mepolish-build.jar:${polish.home}/import/jdom.jar:${polish.home}/import/proguard.jar:${polish.home}/yguard-lib.jar:${wtk.home}/wtklib/kenv.zip"/>

also it shows the same error in almost all tags under j2mepolish tag like info,deviceRequirements,build etc.

but i could run the xml file from IntelliJ itself.

plz suggest some ways to remove this systax highlighting problem

Thanks,
Nidheesh.P
 
Mark Spritzler
ranger
Posts: 17344
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah that's always the fun ones.

Well there are a couple of ways.

1. The tags are in a jar or a DTD, and putting that in the classpath works.
2. There is also a place to add tags that are valid, but you type them in yourself. So if there are lots of tags, then you type a lot into the settings area.

I am going to start up IntelliJ to see if I can find that setting. I don't recall exactly where it is. And it might just be for javadoc tags, like those you use in XDoclet.

Mark
 
Mark Spritzler
ranger
Posts: 17344
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, it's for Javadoc tags. But that is in the Errors Settings. Select the "Unknown JavaDoc Tags" on the left. On the right will be a textbox to add unkonw tags.

Mark
 
Villains always have antidotes. They're funny that way. Here's an antidote disquised as a tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!