Win a copy of Learning OpenStack Networking: Build a solid foundation in virtual networking technologies for OpenStack-based clouds this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

J2ME Polish in IntelliJ IDEA  RSS feed

 
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,
How can i integrate J2MEPolish with IntelliJ IDEA 4.5.
I am using WTK2.1 and j2mepolish 1.2.4

Thanks u

Nidheesh.P
 
ranger
Sheriff
Posts: 17314
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I believe you have to have your project point to the jar files for J2ME Polish, now you will be able to access their classes. In the Project Settings there is a part for "Paths" in that screen there is a tab for "libraries/classpath". CLick the Add Jar/Classpath button, then select the jar files that you want to add to your classpath, and voila.

Mark
 
Nidheesh Puthalath
Ranch Hand
Posts: 30
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thank u Mark.

That is done.
but still IntelliJ shows syntax errors(editor shows red color) in the classpath property of taskdef tag.
below is the taskdef tag of my build.xml file.

<taskdef name="j2mepolish"
classname="de.enough.polish.ant.PolishTask"
classpath="${polish.home}/import/enough-j2mepolish-build.jar:${polish.home}/import/jdom.jar:${polish.home}/import/proguard.jar:${polish.home}/yguard-lib.jar:${wtk.home}/wtklib/kenv.zip"/>

also it shows the same error in almost all tags under j2mepolish tag like info,deviceRequirements,build etc.

but i could run the xml file from IntelliJ itself.

plz suggest some ways to remove this systax highlighting problem

Thanks,
Nidheesh.P
 
Mark Spritzler
ranger
Sheriff
Posts: 17314
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah that's always the fun ones.

Well there are a couple of ways.

1. The tags are in a jar or a DTD, and putting that in the classpath works.
2. There is also a place to add tags that are valid, but you type them in yourself. So if there are lots of tags, then you type a lot into the settings area.

I am going to start up IntelliJ to see if I can find that setting. I don't recall exactly where it is. And it might just be for javadoc tags, like those you use in XDoclet.

Mark
 
Mark Spritzler
ranger
Sheriff
Posts: 17314
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, it's for Javadoc tags. But that is in the Errors Settings. Select the "Unknown JavaDoc Tags" on the left. On the right will be a textbox to add unkonw tags.

Mark
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!