Win a copy of Machine Learning with TensorFlow this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Bear Bibeault
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • salvin francis
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Frits Walraven
Bartenders:
  • Jj Roberts
  • Carey Brown
  • Scott Selikoff

Accessing a SiteMinder protected page in Midlet

 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
I am trying to access a SiteMinder protected webpage in my midlet but not able to. Once I am authenticated, I am supposed to recieve a cookie by name SMSESSION. That cookie is not coming back. Other non-Siteminder cookies are coming as expected. What could be wrong?
If I run the exact same piece of code in the emulator, I get the SMSESSION cookie as well but not when I run it on the device.

Can someone please help?

Thanks and regards,
Roshan
 
Ranch Hand
Posts: 1902
Hibernate Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Have you tested this against another device (model-wise) than the one that you've had your failure with? I'm wondering if it's not perhaps something device-specific that's causing the problem.
 
RoshanLal Dawrani
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,
No, I have not tested it on any other device. Unfortunately, I do not have access to another device that I could have tested it on.

Any thoughts on what could be causing the problem on this particular device? Any potential pointers will be very much appreciated.

Thanks,
Roshan
 
Theodore Casser
Ranch Hand
Posts: 1902
Hibernate Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by RoshanLal Dawrani:
No, I have not tested it on any other device. Unfortunately, I do not have access to another device that I could have tested it on.

Any thoughts on what could be causing the problem on this particular device? Any potential pointers will be very much appreciated.



Well, without testing it on another device (and the fact that you've said it works in the emulator), we can't rule out that it's not a device-specific problem. The fact that it's working in the emulator would encourage me that this might be the case.

Though... you've also not mentioned what device this is.
 
RoshanLal Dawrani
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
My mistake. The device I am using is Nokia 6600.
 
I love a woman who dresses in stainless steel ... and carries tiny ads:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic