Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

j2me app can be installed in all phones?

 
Nicky Eng
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i have a doubt but i can't get any answer by searching google or yahoo.

Is j2me application can be installed in ALL types of the CHEAPEST phone?

for example: all nokia phone, all motorola phone , all SE phone, etc ?

can it be installed in all?

from
Nick
 
Tim Holloway
Saloon Keeper
Posts: 18367
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Not only can it not be installed in all the cheap phones, Sprint doesn't support J2ME in their top--of-the-line HTC phones (they run Windows Mobile).

I have installed the IBM WebSphere Micro Edition JVM in it, buy Spring won't help me if it doesn't work. And IBM charges $5/phone for commercial implementations.
 
Nicky Eng
Ranch Hand
Posts: 378
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
no one knows about nokia or motorola ?

 
Tim Holloway
Saloon Keeper
Posts: 18367
56
Android Eclipse IDE Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nokia and Motorola have good Java support. I don't know if every phone they sell has Java, but many of them do.
 
Majid Asgari Bidhendi
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello!
j2me applications must be run on devices using MIDP1.0 or MIDP2.0
here is a list for midp2 devices:

http://www.j2mepolish.org/devices/midp2.html

be successful

Hyde(not�) : Majid Asgari Bidhendi
Homepage/Blog: http://360.yahoo.com/asgary_ma
Email: majid.asgari@gmail.com
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic