Win a copy of 97 Things Every Java Programmer Should Know this week in the Java in General forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Bad Magic Number

 
Ranch Hand
Posts: 82
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all
I am trying to hit an applet through an iplanet web connector.
The scenario is machine 1 is the web server (iplanet 4.1) . machine 2 is app
server (iplanet 6.0 sp2)
The web connector is configured for handling all the requests to machine2
that refer to the app server.
when i place my jar (containing the applet classes) on the app server and
then try to open it through a jsp on the app server itself , it
throws a
java.lang.ClassFormatError: com/niit/cliks/te/web/TestingEngine (Bad magic
number)
exception.
But if i try with the same jar file on the web server (the same as running
the app server( - i.e. machine 2 ) the jar works just fine.
can anybody put some light on the issue. I am in a very tight deadline
situation.
thanks and regards
raghav..

PS - the applet is not signed and i don't wish (and plan) to sign it.

------------------
 
Lasagna is spaghetti flvored cake. Just like this tiny ad:
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic