• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Jeanne Boyarsky
  • Junilu Lacar
  • Henry Wong
Sheriffs:
  • Ron McLeod
  • Devaka Cooray
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Frits Walraven
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • salvin francis
  • fred rosenberger

Swing applet won't run. load class not found.

 
Ranch Hand
Posts: 189
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a Swing Applet which is deployed and runs fine on at least one browsing client machine.
On another PC, when accessing this html page (which has HTML converted OBJECT and EMBED tags) the status message "load class CatApplet.class not found" is displayed and the applet won't run.
I know for a fact that the CatApplet.class is available in the web server's directory, and according to the logs is gotten successfully on the other machine. The first time I tried to run on the "problem" PC, I went through a Java Plug-in installation dialogue process happened automatically.
What could be responsible for this applet failure?
 
Ranch Hand
Posts: 1492
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi John,
I ran into this same problem about a year ago. The problem was with NS on Windows. I fixed the problem by removing the CLASSPATH environment variable, go figure! Give that a try and see if it works for you...
Regards,
Manfred.
 
Oh the stink of it! Smell my tiny ad!
Devious Experiments for a Truly Passive Greenhouse!
https://www.kickstarter.com/projects/paulwheaton/greenhouse-1
    Bookmark Topic Watch Topic
  • New Topic