Win a copy of The Little Book of Impediments (e-book only) this week in the Agile and Other Processes forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Applet that requires plugin

 
Marcos R Oliveira
Ranch Hand
Posts: 62
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi, folks,
I wrote an Applet that displays a line graph and five labels showing values about this graphic. This applet is made of three classes.
Below are the only imports I use:
import java.awt.*;
import java.awt.event.*;
import java.applet.*;
Even not using Swing (javax.swing.*), this Applet only works properly if I have a plugin installed on the client machine: labels are shown, but not the graphic.
Does anyone know what�s the problem here? What, in my applet can be asking for a plugin?
Thanks in advance for all those with patience to read this post,
Marcos.
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch!
I'm not up to date on all of the plug-in requirements, etc. If I were you, I'd try compiling using -target 1.1 and see if that would solve the problem. Using this option, the compiled class files will be larger (so I've been told - and it makes sense that they would be). For more details on this option and others, see Sun's description of javac - Java programming language compiler.
Good Luck.
 
Marcos R Oliveira
Ranch Hand
Posts: 62
1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That�s right, Dirk!
That was everything I had to know to get thinks working the way I wanted!
Thank you so much!
Sincerely,
Marcos.
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hey cool! I was wondering if that whole javac -target [version] ever actually worked for somebody.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic