• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Applet doesn't work with one specific user.

 
brad ryan
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a signed applet. It has been working well it now. But one of the users complained that it throws out java.lang.ClassNotFoundException when he runs the applet. I tested on other computers and it is still working & it is strange that it doesn't work on that user's PC. I think it is something to do with the browser settings. please suggest me what could be done to overcome this.
Few things to be noted :
1. The PC on which i got this exception has IE 5.
2. It makes use of jre 1.3.1_01
3. Under Java (Sun)(in Tools --> Internat Options -->Advanced)
Use java2 v 1.3.1_01 for applets is enabled
4. Under Microsoft VM (in Tools --> Internat Options -->Advanced)
JIT compiler for virtual machine is enabled.
I tried enabling & disabling 3 or 4 & 3 and 4 also. It din't work. I still believe it's something to do with the browser settings.

One strange thing I observed yesterday was that when I tried to login to the same PC with a different user Id & password the applet works well.
To make it more clear, The applet doesnot display in Jim's PC when I login with Jim's ID. but when I login with my ID or Tom's ID or any other ID in Jim's PC, the applet is displayed and it works well. The applet also works well on other PC's also. This is a problem with one particular login..Is it something to do with any settings ?
I tried by all means to fix the problem. But still can't. I tried logging in with Jim's ID into other PC's it work perfectly well.(It's only Jim's ID + Jim's PC that doesn't work. Anyother aombinations work..i.e Jim's ID & other PC's & other IDs and Jims PC) Is it something to do with Jim's profile on his computer or could there be anything else that does the mischief ? Please see me thru this problem.
I aprreciate your help & suggesttions..
 
Rob Ross
Bartender
Posts: 2205
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi "br,"
Welcome to JavaRanch!
Please change your name to comply with the naming policy to which you agreed when you registered here..

For your publicly displayed name,
use a first name, a space, and a last name.

You can change your name:
here

You can also find the naming policy:
here
Thank You!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic