Win a copy of Cloud Native PatternsE this week in the Cloud forum
or Natural Language Processing in the AI/ML forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Devaka Cooray
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Knute Snortum
  • Rob Spoor
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Piet Souris
  • Stephan van Hulst
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

NT Problem..

 
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All,
I am experincing a strange problem..
on IE ,
I am poping a dialog box from windows,
when i press a button.
Previously this part of the code was built in 1.1.6 now we moved to 1.3.1.
but now when i press the button IE hangs...
Console does not show any expection thrown also.
Further
i IE ,interenet options ->advanced ,
change the VM from Sun to Microsoft
the dialog box popups
I works fine.. ;-)
Note:- Dialog Box has lot of depreciated API's..
what should i do..
Thanks and Regards
vinaya
 
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't exactly understand your question. You mentioned that your fix works fine. Is the question about not using the deprecated methods? If so, which one(s) in particular?
 
vinaya kumar
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ops! i think i confused
let me try explain my problem
1.1.6 built applet code.. -->run in IE--> Press
the button in applet -->dialog is invoked
1.3.1 built applet code -->run in IE--> Press
the button in applet -->dialog does not come ->
IE hangs
When built 1.3.1 i get the warnings of deprecated apis.. too many warnings..
workaround for this
---------------------
IE-> change jvm from sun --> microsoft jvm
then everything works fine
------------------------

Problem
-------------
i am not clear why the problem
[dialog box with 1.3.1 not showing and ie hangs
] is happening..

Hope i am clear
Thanks a lot
Regards
vinaya
 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI,
try to change
<applet.....></applet>
by
<OBJECT classid="clsid:8AD9C840-044E-11D1-B3E9-00805F499D93"
WIDTH = "600" HEIGHT = "136" codebase="http://java.sun.com/products/plugin/1.2/jinstall-12-win32.cab#Version=1,2,0,0">
<PARAM NAME = CODE VALUE = "(your class).class" >
<PARAM NAME="type" VALUE="application/x-java-applet;version=1.2">
<COMMENT>
<EMBED type="application/x-java-applet;version=1.2" java_CODE = "(your class).class" WIDTH = "600" HEIGHT = "136" pluginspage="http://java.sun.com/products/plugin/1.2/plugin-install.html"><NOEMBED></COMMENT>
</NOEMBED></EMBED>
</OBJECT>
It's not clear for me
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!