Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Problem with classes in Jar

 
Ranch Hand
Posts: 72
Eclipse IDE Firefox Browser Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I have two applets in different packages extending an applet from someother package.

Applet A is replica of Applet B above. they both have a textfield and button to transfer texts from each other.
now the html is like this

both the jars have the respective Applet classes and their parent class.
now this setting produces a NoClassDefFoundError when I try to send a text from one applet to the other.
And if I mention both the jars in archive attrib then they work. if I change the order (1.jar,2.jar in one tag and 2.jar,1.jar in another) then they throw ClassCastException.
I am very much puzzled by this behaviour.
I use IE 5.0 and Phoenix 0.4 with JRE Plug-in version 1.4.0_01-ea. Could someone throw some light?
thanks and regards
Ravee.
 
Don't listen to Steve. Just read this tiny ad:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic