• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Jeanne Boyarsky
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
Sheriffs:
  • Paul Clapham
  • Junilu Lacar
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Ganesh Patekar
  • Tim Moores
  • Pete Letkeman
  • Stephan van Hulst
Bartenders:
  • Carey Brown
  • Tim Holloway
  • Joe Ess

Force download plugin to Client  RSS feed

 
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All:
I am running my applet based application on Windows 2000. Trying to achieve the following:
> Server side of the application uses jdk1.3.1_07. Hence I want the users to stick to the same JVM on client as well to avoid any incomprehensible problems.
> Added Object tag with static classid. The code looks like this:
< OBJECT ID="someObject" CLASSID="clsid:CAFEEFAC-0013-0001-0007-ABCDEFFEDCBA" width="100%" height="0"
codebase="http://java.sun.com/products/plugin/1.3.1/jinstall-131-win32.cab#Version=1,3,1,7" >
< PARAM name="TYPE" value="application/x-java-applet;jpi-version=1.3.1_07" >
This should force client to download plugin ver 1.3.1_07 if there not one installed. Instead this code sometime cause my borwser to crash. At other times, it just download jre1.3.1 and does that on every visit to the page. Should not repeat the download.
What I am doing wrong? I have spent hrs trying to figure out. Any help would be greatly appreciated.
Thanks.
Y
 
Sheriff
Posts: 9087
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not sure about the crashing part, but you will download 1.3.1 again everytime if the client uses a different version between visits to your page, whether that version is lower (1.3.1) or higher (1.4).
 
Yatharth Kumar
Greenhorn
Posts: 14
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Marylyn,
Thanks for you response. My requirement is that client should download a specific version (1.3.1_04) even if a later version is installed.
I have got it working though. I guess the class id was not correct. When I generated the code with htmlconverter (Sun) using jre 1.3.1_04, it worked fine.
Thanks,
Y
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!