• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

version mismatch error

 
dale virden
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
When I compile at home with the latest version of the SDK my applets will not run on the browsers where I work. I get a major version mismatch error. If I compile on the Unix development box here with a much older version of Java then the applets run without error. Apparently applets are not backwardly compataible? If this is true then am I to understand that I have to "dumb down" the applet by compiling it on the oldest version I can find if I want to make it more accessible?
 
Marilyn de Queiroz
Sheriff
Posts: 9066
12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What type of browsers do you have where you work?
 
Mathias Nilsson
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nope! You can use javac myApplet.java -target 1.1
// Mathias
 
dale virden
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"You can use javac myApplet.java -target 1.1" Thanks!! I had some pretty good results with this. Not 100% but a teriffic improvement. My applets seemed to work just fine on the older version of IE at work. Still seems to be a problem with the older version of Netscape. I will do some more checking and if I can't find an answer I will post version numbers for the browsers. One small advantage in working for a company that drags it's feet about upgrading to newer browsers. They are furnishing a nice test environment for stuff I am writing at home.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic