• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Applet is loaded but not displayed

 
Joachim Christoph
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!

My program contains several pages each with several applets. One page, containing 12 applets, displays the details of a dataset. All datasets are displayed in a JTable in another applet and another page. It is possible to jump from one page to the other and back and again and so on.
Normally the program works fine, but sometimes it crashes: In IE, the status bar says that all applets are started (confirmed by dubugging), but it is nothing displayed but an empty page, not even html. In firefox you get an error advising

java.lang.NullPointerException
at sun.plugin.AppletViewer.loadJarFiles(Unknown Source)
at sun.applet.AppletPanel.runLoader(Unknown Source)
at sun.spplet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Does someone know this problem, or better, knows what to do?
Regards, Joachim


PS: First I thaught it is a cache-problem, but there is a randomID and the html-metas
<meta http-equiv="cache-control" content="no-cache">
<meta http-equiv="expires" content="0">.
 
Joachim Christoph
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OK, I found the problem; the page was loaded 2 times because of 2 identic Listeners at a JTable...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic