Win a copy of Python Continuous Integration and Delivery this week in the Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Bear Bibeault
  • Paul Clapham
  • Jeanne Boyarsky
Sheriffs:
  • Devaka Cooray
  • Junilu Lacar
  • Tim Cooke
Saloon Keepers:
  • Tim Moores
  • Ron McLeod
  • Tim Holloway
  • Claude Moore
  • Stephan van Hulst
Bartenders:
  • Winston Gutkowski
  • Carey Brown
  • Frits Walraven

Applet only works with one Java version  RSS feed

 
Sheriff
Posts: 21638
101
Chrome Eclipse IDE Java Spring Ubuntu VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've written an applet inside a signed JAR (needs a lot of OS interaction) which works perfectly in Java 1.4.2, which it's also written in.

However, when I try it with different Java versions (1.4.1 and 1.5 are tested) I get the following error:The class is com.hecc.ivr.viewer.ViewerApplet.
I haven't used any special Manifest to create the JAR, which is signed using a local keytool.

The HTML code:This installs Java 1.4.1_03 (most users have that one) if no newer version is installed - if I replace it with 1.4.2_06 (the version used to compile) it still does not work.

Anyone know how I can solve this without requiring Java 1.4.2?
 
author and iconoclast
Posts: 24203
43
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HTTP response code 401 is "Unauthorized". Are you sure this is a Java version thing, and not a security thing? Is the web server where the applet lives allowed to send to JAR file to the client machine you're testing on?
 
Rob Spoor
Sheriff
Posts: 21638
101
Chrome Eclipse IDE Java Spring Ubuntu VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You know, that is a good question.
The web directory it is in now has IIS security on it, so that might be the problem. If so, question is why 1.4.2 does work.

I'll test this tomorrow on my test server (IIS but no security).
 
Rob Spoor
Sheriff
Posts: 21638
101
Chrome Eclipse IDE Java Spring Ubuntu VI Editor Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Ok, security is the problem, and only in Java 1.4.1 - even a machine with only 1.5 worked (although I had to login twice).

Guess I'll have to change the HTML page to require 1.4.2_06 as the minimum.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!