• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Applet Compilation Problems (states to recompile)

 
Krista Meek
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm trying to compile a simple java applet but when the compile process completes I am given the following:
---------------------------------------------------------------------------
Note: C:\krista\JCreator LE\MyProjects\Chat.java uses or overrides a deprecated API.
Note: Recompile with -Xlint eprecation for details.

Process completed.
---------------------------------------------------------------------------
It compiled fine before I added the following code:


I am using jdk1.5.0 and jre1.5.0

Any suggestions would be appreciated.

Thanks.
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24212
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Did you do what the warning suggests, and add the -Xlint:deprecation switch to the javac command line?
 
Ulf Dittmer
Rancher
Posts: 42969
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's just a warning, not an error. Are you concerned about using deprecated APIs? Bacuse that is what the handleEvent method is.
 
Krista Meek
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Actually, now that I understand what the warning is I am ok with that part. Thnks for the help.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic