Win a copy of Java Concurrency Live Lessons this week in the Threads forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Internet Explorer always using the latest jre installed.  RSS feed

 
Dar Var
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I have an applet that uses static versioning so the user must have 1.4.2_03 jre installed. If not it will be downloaded.

<OBJECT classid="clsid:CAFEEFAC-0014-0002-0003-ABCDEFFEDCBA"

However if the user has 1.4.2_03 and 1.5.x the applet uses 1.5.x even though the object tag uses the above classid for 1.4.2_03.

It seems Internet Explorer will always use the latest jre installed. The Java Console in IE shows:

Java Plug-in 1.5.0_09
Using JRE version 1.5.0_09 Java HotSpot(TM) Client VM

Is this the case?? What if my applet code doesn't work with 1.5
 
Ulf Dittmer
Rancher
Posts: 42970
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Why would code that is working with 1.4 not work with 5.0? By relying on a bug in 1.4? Or by being hit with a new bug in 5.0?

5.0 has been out for years. I would suggest to qualify your application for 5.0 if you haven't done so yet.
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!