Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

is khalid wrong?

 
kay jee
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ch\u0061r a = 'a';
Is a valid declaration right.
but my IDE doesn't think so. His name is eclipse 3.2. and im using jdk1.5
Please help
This is wat it says:
Got an exception - unexpected char: '\'
 
Srinivasan thoyyeti
Ranch Hand
Posts: 557
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Kay jee,

It can't say like that.
Probably you would have given two slashes(\\ or /).

No other guess from me.
 
Wiyanto Ngasinur
Ranch Hand
Posts: 34
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Probably you would have given two slashes(\\ or /).


nope i tried with \, work correctly in my eclipse 3.2
 
kay jee
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hmm. any other guesses ppl? its just not working on my IDE. what cud be the reason
 
Marcus Green
arch rival
Rancher
Posts: 2813
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What happens when you try without using eclipse?
 
kay jee
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
it compiles
 
Abhishek Bharti
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Are you sure you have not copy n paste the code while trying on IDE, try by typing through keyboard or something. This must be your system specific problem.
 
Sourin K. Sen
Ranch Hand
Posts: 86
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's working on my eclipse 3.2 as well. There must be something wrong with your eclipse. Check it's settings properly.
 
Prashant Saraf
Ranch Hand
Posts: 57
Eclipse IDE Java Linux
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hay it's working fine i try this in Eclipse 3.2
 
kay jee
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yup its working fine everywher except my pc.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic