• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

which should I take??

 
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
welcome ranchers, I ask this question but no one in my college can answer, which exam should I take??
SCJP 1.4 OR 5.0

I read the objectives of each, but can't decide which is suiteable??

please help me decide!
 
Java Cowboy
Posts: 16084
88
Android Scala IntelliJ IDE Spring Java
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
SCJP 5, because SCJP 1.4 is for Java 1.4, which is an old version of Java.
 
Ranch Hand
Posts: 100
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you should go for 5, because some major changes were introduced from 1.4 to 5. and 6 is just slightly different than 5, regarding exam. so you could even go for 6.
every version has some time span that it lives, in my opinion 1.4 is approaching it limit. although it is still widely used, i think doing 5 will make you more up-to-date and will keep you in the busyness longer.
and at last, i think you should really go for newer version, simply because it has some features that will make your life easier, like generics and enhanced for loop...
wish you good luck
 
Ahmed Gaber
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
so,
from the previous replies,

I've the kathy sierra book for 1.4
can I use it to begin preparation,

or I need newer version
R the content changes completly??
 
Ranch Hand
Posts: 90
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
you will better to follow scjp5 by kathy&bert,it is an updated version which includes enum,autobxing ....
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You do need a new version, otherwise you'll miss some important topics.
 
WHAT is your favorite color? Blue, no yellow, ahhhhhhh! Tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic