• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JavaComm - Opening a parallel port for reading

Luis Alfredo Perez
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm trying to open a parallel port for reading but the API keeps telling me that my port doesn't support reading mode. This happens when I try to open an input stream for the port and when I explicitly change the port mode.
I'm working in a windows 2000 with the JRE 1.3.1_02 and javacomm 2.0.
I ran the ParallelPort monitor that ships with javacomm 2.0 (as a sample) and I can't switch the ports mode.
I check the BIOS configuration and the parallel port is configured in ECP mode.
The printer is an Olivetti PR 2 that supports IEEE 1284 in ECP mode.
I tried to test the parallel port monitor in another hardware (Compaq PIV) with windows 2000 and I observed the same behaviour.
Does anybody knows what's happening?
I have not found any reported bug addressing the same problem.
Thanks in advance.
Luis Alfredo P�rez
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic