Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JNI partial success  RSS feed

 
Mike Feldmeier
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Greetings all,

Hmm.. how to best explain this..



I have been getting a "UnsatisfiedLinkError: no jni-test found in java.library.path" message all day.

I've tried...
  • putting the dll in the current directory and system directories (c:\windows, c:\windows\system32, etc.).
  • setting java.library.path to the current directory where the dll is.


  • After spending all morning doing this, I try..



    ..and it WORKS. I can do a workaround to construct the absolute path each time, but I'd really like to find out why this is doing this.

    Incidentally, I created another dummy project, and loadLibrary worked, even though the project settings are identical.

    Does anyone see anything obvious about this that I've screwed up?

    Thanks,
    Mike
    [ August 19, 2004: Message edited by: Mike Feldmeier ]
     
    • Post Reply Bookmark Topic Watch Topic
    • New Topic
    Boost this thread!