• Post Reply Bookmark Topic Watch Topic
  • New Topic

ImageIO metadata problem  RSS feed

 
Christian Mousel
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I have an TIFF-file with an image at a low resolution. This image needs to be at a resolution of 1000 dpi for printing in scientific articles. From what I have seen on the net, the way to go to change the image resolution is by changing the metadata of the image.

So here is what I try to do.



where the class MetadataUtilities is as follows:


The problem is, when I print the metadata at the end of my main program, it displays what I want it to.

<TIFFField number="282" name="XResolution">
<TIFFRationals>
<TIFFRational value="1/1000"/>
</TIFFRationals>
</TIFFField>
<TIFFField number="283" name="YResolution">
<TIFFRationals>
<TIFFRational value="1/1000"/>
</TIFFRationals>
</TIFFField>


But if i load the same image the next time, or if I chack the properties of the image with a right-click the resolution is not changed.
It still displays


<TIFFField number="282" name="XResolution">
<TIFFRationals>
<TIFFRational value="1/1"/>
</TIFFRationals>
</TIFFField>
<TIFFField number="283" name="YResolution">
<TIFFRationals>
<TIFFRational value="1/1"/>
</TIFFRationals>
</TIFFField>


Any help on this would be geatly appreciated, as I am starting to get really depressed by this

Thanks in advance

[ May 23, 2006: Message edited by: Christian Mousel ]
[ May 23, 2006: Message edited by: Christian Mousel ]
 
Christian Mousel
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Nevermind. The problem got solved in the meantime.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!