Win a copy of Spark in Action this week in the Open Source Projects forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

JSP Bean error

 
Ranch Hand
Posts: 68
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I am returning an "array of beans" from a servlet to a JSP. When I try to display these in my JSP using <jsp:useBean> I get the default values for the bean, however if I use scriptlets, I get the correct values.

In the following fragment, the first scriptlet which uses student.getXXX() works perfectly and displays 3 records, wheread the second part which tries to achieve the same using a bean, displays 3 records with ID = -1 and name = "" since these are their default values.
Please assist me in this problem.
Thanks in advance,
Anoop

[This message has been edited by Nair Anoop (edited November 14, 2001).]
[This message has been edited by Nair Anoop (edited November 14, 2001).]
 
    Bookmark Topic Watch Topic
  • New Topic