• Post Reply Bookmark Topic Watch Topic
  • New Topic

Problem faced in Tomcat 4.0.4

 
Sid Scud
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
HI ALl
I am working on an application ported in Tomcat. This works fine in JRun 3.1.
Bu I am getting the following error in Tomcat 4.04 ..
org.apache.jasper.JasperException: Unable to compile class for JSP
E:\Tomcat\jakarta-tomcat-4.0.4\work\Standalone\localhost\testapp\accounts\Test$jsp.java:16: Class or interface declaration expected.
import javax.servlet.*;
^
E:\Tomcat\jakarta-tomcat-4.0.4\work\Standalone\localhost\testapp\accounts\Test$jsp.java:22: Superclass org.apache.jsp.HttpJspBase of class org.apache.jsp.Test$jsp not found.
public class Test$jsp extends HttpJspBase {

Can someone tell me where things are going wrong?
Thanks in advance..
-Siddharth
 
chanoch wiggers
Author
Ranch Hand
Posts: 245
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
did you check the installation of tomcat before you installed you code? also, have you got alittle more code than you've shown? I've found that JRun moves things around such that an expanded war file wont run on other compliant servers but in my case it was because it was saving web.xml in an incorrect format etc not any messing with the class files.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!